Battery isnt charging.

Moderators: AE25, BOBLOOK, pufito18

Battery isnt charging.

Postby Catylistic » Wed Jul 15, 2015 2:29 am

About a month ago the CHG light on my '79 corolla wagon started going on but fading away at high rpms. It was only about a week of owning it that this happened and I didnt think to look up what it meant. Not too long after that the light wouldn't fade at all. At this point I decided to take the alternator out and get it tested. It was bad. Bought a new one right there hooked it up and it still isnt charging. Any ideas or help? Also a picture if anyone is curious.
Image
Catylistic
 
Posts: 7
Joined: Sun Jun 28, 2015 3:35 am

Re: Battery isnt charging.

Postby BOBLOOK » Wed Jul 15, 2015 5:19 pm

Voltage regulator bad ?
The day we learn to think
User avatar
BOBLOOK
 
Posts: 2262
Joined: Wed Jun 19, 2013 7:32 pm
Location: Under a bonned in Netherlands.

Re: Battery isnt charging.

Postby Catylistic » Fri Jul 17, 2015 12:15 am

BOBLOOK wrote:Voltage regulator bad ?

Where would I find that?
Catylistic
 
Posts: 7
Joined: Sun Jun 28, 2015 3:35 am

Re: Battery isnt charging.

Postby BOBLOOK » Fri Jul 17, 2015 4:00 pm

Here !
Attachments
maxresdefault.jpg
maxresdefault.jpg (238.39 KiB) Viewed 2951 times
The day we learn to think
User avatar
BOBLOOK
 
Posts: 2262
Joined: Wed Jun 19, 2013 7:32 pm
Location: Under a bonned in Netherlands.

Re: Battery isnt charging.

Postby Catylistic » Thu Oct 08, 2015 2:57 am

BOBLOOK wrote:Here !

I replaced the reg and it charges now (woohoo!) But now when i turn the car all the way off the chg light stays on and drains the battery if i leave it off for more than 24 hours
Catylistic
 
Posts: 7
Joined: Sun Jun 28, 2015 3:35 am

Re: Battery isnt charging.

Postby BOBLOOK » Thu Oct 08, 2015 8:28 pm

Sound that you-re alternator maybe bad?
When you disconnect the battery cable then reconnect it back do you hear an click sound??
If yes on diode is blow in the alternator
The day we learn to think
User avatar
BOBLOOK
 
Posts: 2262
Joined: Wed Jun 19, 2013 7:32 pm
Location: Under a bonned in Netherlands.

Re: Battery isnt charging.

Postby Catylistic » Thu Oct 08, 2015 10:27 pm

BOBLOOK wrote:Sound that you-re alternator maybe bad?
When you disconnect the battery cable then reconnect it back do you hear an click sound??
If yes on diode is blow in the alternator

It does click. But it also will stay on if i disconnect the battery telling me its doing its job. Is it still possible for it to charge the battery with a bad diode?
Catylistic
 
Posts: 7
Joined: Sun Jun 28, 2015 3:35 am

Re: Battery isnt charging.

Postby BOBLOOK » Fri Oct 09, 2015 9:00 pm

Yes it will charge just fine just the trio circuit diode is blow

Image
The day we learn to think
User avatar
BOBLOOK
 
Posts: 2262
Joined: Wed Jun 19, 2013 7:32 pm
Location: Under a bonned in Netherlands.

Re: Battery isnt charging.

Postby Catylistic » Fri Oct 09, 2015 11:32 pm

BOBLOOK wrote:Yes it will charge just fine just the trio circuit diode is blow

Image

So i guess now i just have figure whats causing it to blow. If i just replace the alt its just going to blow again right?
Catylistic
 
Posts: 7
Joined: Sun Jun 28, 2015 3:35 am

Re: Battery isnt charging.

Postby Admin » Sat Oct 10, 2015 11:49 am

In many case is uncertain what causes the diode to blow. The cathode side need to spare the voltage that trigger the charge light. Thats is not happed in youre case causing the circuit to stay on and drain the battery
User avatar
Admin
Site Admin
 
Posts: 79
Joined: Fri Jun 14, 2013 10:06 pm

Next

Return to Electrical

Who is online

Users browsing this forum: No registered users and 3 guests

cron