My TE51 was lost

Moderators: AE25, BOBLOOK, pufito18

My TE51 was lost

Postby gotboost » Tue Sep 26, 2017 2:49 am

I figured I'd show the world one last time. My wonderful TE51 was tboned in a parking lot a week ago. The frame is bent badly. Hit right between the wheels.

Sorry for the bad news guys.

Image

Image

Image

I kept her to start again. If anyone knows where I can find a 1st gen celica liftback to start again. I don't want to try to do her again. I feel a recreation would never be as good.

If you want to see more of her check out doppelgänger customs on Facebook.
gotboost
 
Posts: 9
Joined: Sun Oct 18, 2015 6:47 pm

Re: My TE51 was lost

Postby gotboost » Tue Sep 26, 2017 3:10 am

I want you guys to know she drove me everywhere. I never turned her down. 7 years never failed to get me home. And even after the wreck. Drove me home.

Daily driven, loved even more.
gotboost
 
Posts: 9
Joined: Sun Oct 18, 2015 6:47 pm

Re: My TE51 was lost

Postby AE25 » Tue Sep 26, 2017 10:43 am

oh shiiiiite. so sorry man! that looks like a labour of love. I hope that everyone is safe and well. Cars can be replaced ;)

Image
AE25
Moderator
 
Posts: 93
Joined: Tue Jul 16, 2013 9:03 am
Location: Auckland NZ

Re: My TE51 was lost

Postby gotboost » Tue Sep 26, 2017 5:31 pm

Thanks ae25 for posting her picture for me. Indeed a labour of love. You picked one of the best. Everyone walked away thankfully.
gotboost
 
Posts: 9
Joined: Sun Oct 18, 2015 6:47 pm

Re: My TE51 was lost

Postby BOBLOOK » Wed Sep 27, 2017 4:47 pm

Very sad nice looking Te51 sorry for your lost
The day we learn to think
User avatar
BOBLOOK
 
Posts: 2257
Joined: Wed Jun 19, 2013 7:32 pm
Location: Under a bonned in Netherlands.

Re: My TE51 was lost

Postby BOBLOOK » Wed Sep 27, 2017 4:51 pm

21766774_1958884161062868_4573604018146050278_n.jpg
21766774_1958884161062868_4573604018146050278_n.jpg (76.23 KiB) Viewed 898 times
22008092_1958884131062871_465248703944744128_n.jpg
22008092_1958884131062871_465248703944744128_n.jpg (66.01 KiB) Viewed 898 times
gotboost wrote:I figured I'd show the world one last time. My wonderful TE51 was tboned in a parking lot a week ago. The frame is bent badly. Hit right between the wheels.

Sorry for the bad news guys.



I kept her to start again. If anyone knows where I can find a 1st gen celica liftback to start again. I don't want to try to do her again. I feel a recreation would never be as good.

If you want to see more of her check out doppelgänger customs on Facebook.
The day we learn to think
User avatar
BOBLOOK
 
Posts: 2257
Joined: Wed Jun 19, 2013 7:32 pm
Location: Under a bonned in Netherlands.

Re: My TE51 was lost

Postby gotboost » Fri Sep 29, 2017 3:05 am

Thanks Boblook.

How did you get it to post?
Not sure what I did wrong.
gotboost
 
Posts: 9
Joined: Sun Oct 18, 2015 6:47 pm

Re: My TE51 was lost

Postby BOBLOOK » Sat Sep 30, 2017 7:45 am

gotboost wrote:Thanks Boblook.

How did you get it to post?
Not sure what I did wrong.


You posted the facebook link reason it didn't show,

Try [img]photo%20location%20link[/img]
The day we learn to think
User avatar
BOBLOOK
 
Posts: 2257
Joined: Wed Jun 19, 2013 7:32 pm
Location: Under a bonned in Netherlands.

Re: My TE51 was lost

Postby gotboost » Sun Oct 01, 2017 12:27 am

Ok, thanks. Will do.
gotboost
 
Posts: 9
Joined: Sun Oct 18, 2015 6:47 pm

Re: My TE51 was lost

Postby AE25 » Sun Oct 01, 2017 11:58 am

i right clicked the image, selected 'view image' so it only shows the picture, then right click and save image location. that link is posted with the [img]http:...jpg[/img] tags around it.
AE25
Moderator
 
Posts: 93
Joined: Tue Jul 16, 2013 9:03 am
Location: Auckland NZ

Next

Return to Fun Talk

Who is online

Users browsing this forum: No registered users and 0 guests